Firefox, come tutti sappiamo, ha una grande possibilità di estendere le sue funzioni mediante delle estensioni reperibili in rete. Con il passaggio alla versione 2 molte di queste estensioni (create per firefox 1.5 o 1.6) possono risultare incompatibili, in questo caso prima dobbiamo cercare una versione compatibile qui o qui, se la ricerca non ha dato frutti proviamo a far credere a firefox 2 che l'estensione sia compatibile.

  • scaricare l'xpi dell'estensione non compatibile
  • aprirlo con un programma per gestire archivi (WinZip, WinRar, 7zip o altri)
  • estrarre il file install.rdf
  • aprirlo con un editor di testo e cercare il tag em:maxVersion
  • sostituire il valore presente con 2.0.*
  • riaggiungere il file install.rdf all'archivio .xpi e provare ad installare l'estensione

Non è detto che funzioni sempre, ma provare non costa niente.

link